ServerIron ADX Server Load Balancing Guide
Release 12.0.00
June 15, 2009

Table of Contents Previous Next Print


Server Load Balancing > IPv6 Support for SLB

IPv6 Support for SLB
The commands to configure Server Load Balancing, including configuration of virtual servers, real servers, VIP groups, health check parameters, and others are the same for IPv6 as they are for IPv4. The existing commands have been enhanced to accept either IPv6 or IPv4 addresses. Other than IPv6 addressing, no new commands are necessary for configuring SLB for IPv6 on the ServerIron.
IPv6 and IPv4 commands cannot be combined for a given L47 object definition, however both IPv6 and IPv4 services (reals, virtuals erc.) can co-exist on the same system.
For example, you can have IPv6 VIPs with IPv6 reals servers. At the same time, you can define IPv4 VIPs with IPv4 real servers, but you cannot have IPv6 VIPs for IPv4 real servers and vice versa.
The following shows the configuration steps for a sample IPv6 SLB configuration:
Define IPv6 Real Servers
ServerIron(config)# server real rs3 300::a
ServerIron(config-rs-rs3)# port http
ServerIron(config-rs-rs3)# port http
ServerIron(config-rs-rs3)# port http url "HEAD /"
ServerIron(config-rs-rs3)# port dns
ServerIron(config-rs-rs3)# exit
 
ServerIron(config)# server real rs4 300::5
ServerIron(config-rs-rs4)# port http
ServerIron(config-rs-rs4)# port http
ServerIron(config-rs-rs4)# port http url "HEAD /"
ServerIron(config-rs-rs4)# port dns
ServerIron(config-rs-rs4)# exit
 
Define IPv6 Virtual Servers
ServerIron(config)# server virtual vs2 300::face
ServerIron(config-rs-v45)# port http
ServerIron(config-rs-v45)# port dns
ServerIron(config-rs-v45)# bind http rs3 http rs4 http
ServerIron(config-rs-v45)# bind http rs7 http
ServerIron(config-rs-v45)# bind dns rs5 dns rs6 dns rs7 dns rs3 dns
ServerIron(config-rs-v45)# bind dns rs4 dns
ServerIron(config-rs-v45)# exit
Define IPv4 Real Servers
ServerIron(config)# server real v41 31.31.31.10
ServerIron(config-rs-v41)# port http
ServerIron(config-rs-v41)# port http url "HEAD /"
ServerIron(config-rs-v41)# exit
 
ServerIron(config)# server real v42 31.31.31.11
ServerIron(config-rs-v42)# port http
ServerIron(config-rs-v42)# port http url "HEAD /"
ServerIron(config-rs-v42)# exit
Define IPv4 Virtual Servers
ServerIron(config)# server virtual-name-or-ip v4-v 31.31.31.250
ServerIron(config-vs-v4-v)# sym-priority 200
ServerIron(config-vs-v4-v)# sym-active
ServerIron(config-vs-v4-v)# port http
ServerIron(config-vs-v4-v)# bind http v41 http v42 http v43 http v45 http
ServerIron(config-vs-v4-v)# exit
Define Port Characteristics Using Port Profile
ServerIron(config)# server port 80
ServerIron(config-port-http)# session-sync
ServerIron(config-port-http)# tcp
ServerIron(config)# exit
 
ServerIron(config)server port 53
ServerIron(config-port-dns)# session-sync
ServerIron(config-port-dns)# tcp keepalive disable
ServerIron(config-port-dns)# udp
ServerIron(config)# exit
Define IP Routes
ServerIron(config)# ip route 0.0.0.0 0.0.0.0 40.40.40.5
ServerIron(config)# ipv6 route 700::/64 400::212:f2ff:fea8:1400
ServerIron(config)# exit
VLAN, Tagging and Trunk Definitions
ServerIron(config)# vlan 1 name DEFAULT-VLAN by port
ServerIron(config-vlan-1)# exit
 
ServerIron(config)# vlan 110 by port
ServerIron(config-vlan-10)# tagged ethe 3/3 to 3/4
ServerIron(config-vlan-10)# untagged ethe 3/7
ServerIron(config-vlan-10)# router-interface ve 10
ServerIron(config-vlan-10)# spanning-tree
ServerIron(config-vlan-10)# exit
 
ServerIron(config)# trunk switch ethe 3/3 to 3/4
ServerIron(config)# exit
VRRP-E and VIP group Definitions
ServerIron(config)# interface ethernet 3/1
ServerIron(config-if-3/1)# ip address 40.40.40.1 255.255.255.0
ServerIron(config-if-3/1)# ipv6 address 400::/64 eui-64
 
ServerIron(config)# interface ve 10
ServerIron(config-ve-10)# ip address 31.31.31.1 255.255.255.0
ServerIron(config-ve-10)# ipv6 address 300::/64 eui-64
 
ServerIron(config)# router vrrp-extended
ServerIron(config)# router vrrp-extended-ipv6
 
ServerIron(config)# server vip-group 1
ServerIron(config-vip-group-[1])# vip 300::face
ServerIron(config-vip-group-[1])# vip 31.31.31.250
ServerIron(config-vip-group-[1])# exit
 
ServerIron(config-ve-10)# ipv6 vrrp-extended vrid 1
ServerIron(config-ve-10-vrid-1)# backup
ServerIron(config-ve-10-vrid-1)# ip address fe80::35
ServerIron(config-ve-10-vrid-1)# track-port e 3/1 priority 15
ServerIron(config-ve-10-vrid-1)# enable
ServerIron(config-ve-10-vrid-1)# exit
ServerIron(config-ve-10)# exit
 
ServerIron(config-if-3/1)# ipv6 vrrp-extended vrid 4
ServerIron(config-if-3/1-vrid-5)# backup
ServerIron(config-if-3/1-vrid-5)# ip address fe80::36
ServerIron(config-if-3/1-vrid-5)# vip-group 1
ServerIron(config-if-3/1-vrid-5)# enable
ServerIron(config-if-3/1-vrid-5)# exit
ServerIron(config-if-3/1)# exit
 
ServerIron(config-ve-10)# ip vrrp-extended vrid 3
ServerIron(config-ve-10-vrid-3)# backup
ServerIron(config-ve-10-vrid-3)# ip-address 31.31.31.3
ServerIron(config-ve-10-vrid-3)# track-port e 3/1 priority 15
ServerIron(config-ve-10-vrid-3)# enable
ServerIron(config-ve-10-vrid-3)# exit
 
ServerIron(config-if-3/1)# ip vrrp-extended vrid 5
ServerIron(config-if-3/1-vrid-5)# backup
ServerIron(config-if-3/1-vrid-5)# ip-address 40.40.40.3
ServerIron(config-if-3/1-vrid-5)# enable
ServerIron(config-if-3/1-vrid-5)# exit
Miscellaneous
ServerIron(config)# aaa authentication web-server default local
ServerIron(config)# no enable aaa console
ServerIron(config)# exit
ServerIron(config)# telnet server
ServerIron(config)# username admin password .....
ServerIron(config)# snmp-server
Save the configuration
ServerIron(config)# write memory
NOTE: IPv6 and IPv4 addresses cannot be used under the same service definition. For example, you cannot define IPv4 real servers for IPv6 VIPs and vice versa.
The IPv6 and IPv4 service definitions can co-exist on the same system. That means, you can define IPv4 VIPs with IPv4 real servers and IPv6 VIPs with IPv6 real servers on the same system.

Server Load Balancing > IPv6 Support for SLB

Table of Contents Previous Next Print
Copyright © 2009 Brocade Communications Systems, Inc.