Network OS Administration Guide

Supporting Network OS 6.0.1a

Part Number: 53-1003768-04

Configuring interconnected Ethernet Fabrics

To deploy interconnected Ethernet Fabrics using vLAG, create a port-channel interface on the RBridges that are to be connected. Then add the member interfaces to the port-channel and bring them online. Configure switchport and add the VLANs that are to be allowed over the port-channel. After the port-channels on all the RBridges are online, the vLAG forms automatically on the RBridge that connects to multiple nodes on the other VCS cluster. In the deployment topology shown in Topology for Distributed Ethernet Fabrics using vLAG, the vLAG forms on the RBridges that are part of port-channel Po1 in Data-Centers 1 and 2 that forms VCS 1.

This configuration must be applied on RBridges that connect the two VCS instances. Perform the following task in global configuration mode.

  1. Create a port-channel interface on all RBridges that are directly connected to RBridges in other VCS instances.
    NOTE
    In logical chassis cluster mode, the port-channel is created only from the principal node and is applied globally.
    switch(config)# interface port-channel 300
  2. Verify that the port-channel is created correctly by using the show running-config command.
    switch(config-Port-channel-300)# do show running-config interface port-channel 300
    
    interface Port-channel 300
     vlag ignore-split
     shutdown
  3. Configure the port-channel interface for the switchport trunk and add the VLANs to be allowed on the trunk interface by using the switchport command.
    switch(config-Port-channel-300)# switchport
    switch(config-Port-channel-300)# switchport mode trunk
    switch(config-Port-channel-300)# switchport trunk allowed vlan all
  4. Verify the port-channel interface configuration by using the show running-config command.
    switch(config-Port-channel-300)# do show running-config interface Port-channel 300
    
    interface Port-channel 300
     vlag ignore-split
     switchport
     switchport mode trunk
     switchport trunk allowed vlan all
     switchport trunk tag native-vlan
     spanning-tree shutdown
     shutdown
  5. Add member interfaces to the port-channel interface by using the channel-group command. Do this for all interfaces that must be part of the port-channel.
    switch(conf-if-te-53/0/31)# channel-group 300 mode active type standard
    switch(conf-if-te-53/0/31)# do show running-config interface 
    
    TenGigabitEthernet 53/0/31
    interface TenGigabitEthernet 53/0/31
     fabric isl enable
     fabric trunk enable
     channel-group 300 mode active type standard
     lacp timeout long
     no shutdown
  6. Bring the port-channel online in both VCS instances by executing no shutdown on the port-channel interface.
    switch(config-Port-channel-300)# no shutdown
  7. Verify the port-channel interface configuration by using the show running-config command.
    switch(config-Port-channel-300)# do show running-config interface Port-channel 300
    
    interface Port-channel 300
     vlag ignore-split
     switchport
     switchport mode trunk
     switchport trunk allowed vlan all
     switchport trunk tag native-vlan
     spanning-tree shutdown
     no shutdown
  8. Verify that console RASLogs indicate the formation of the vLAG by using the no shutdown command.
    switch(config-Port-channel-300)# no shutdown
    
    2013/06/17-16:40:53, [NSM-1023], 224126, DCE, INFO, VCS1-51, RBridge ID 51 has joined Port-channel 300. Port-channel is a vLAG with RBridge IDs 52 51.
  9. Verify the formation of the port-channel vLAG by using the show port-channel command.
    switch# show port-channel 300
    LACP Aggregator: Po 300 (vLAG)
    Aggregator type: Standard
    Ignore-split is enabled
      Member rbridges:
        rbridge-id: 51 (2)
        rbridge-id: 52 (2)
      Admin Key: 0010 - Oper Key 0010
      Partner System ID - 0x8000,01-e0-52-00-00-02
      Partner Oper Key 0010
    Member ports on rbridge-id 51:
       Link: Te 51/0/31 (0x19180E801C) sync: 1
       Link: Te 51/0/32 (0x19180F001D) sync: 1