Brocade Security Advisory

http://www.brocade.com/content/dam/common/images/Dotcom/logos/brcd_web_logo.png

 

 

Brocade Security Advisory ID:

BSA-2018- 522

 

Risk Impact:

Medium

Initial Publication Date:

January 05, 2018

 

Workaround:

N/A

Last Updated:

January 12, 2018

 

Component:

HW: CPU

Revision:

1.2: Interim

 

Affected CVE:

CVE-2017-5753, CVE-2017-5715, CVE-2017-5754

 

Summary

In total, security researchers disclosed three variants of CPU Data cache timing abuse. The variants lead to vulnerabilities that take advantage of the implementation of speculative execution of instructions on many modern processors to perform side-channel information disclosure.   An unprivileged local attacker could read privileged memory belonging to other processes or memory allocated to the operating system kernel.

 

The three disclosed variants are:

Variant 1: bounds check bypass (CVE-2017-5753)

Variant 2: branch target injection (CVE-2017-5715)

Variant 3: rogue data cache load (CVE-2017-5754)

Variant 1 and 2 are collectively known as Spectre, the third variant is known as Meltdown.

 

To exploit any of these vulnerabilities, an attacker must be able to download and run a carefully crafted program on the device.

Affected Products

Brocade virtual ADX (vADX)

Fixed in vADX 4000f

 

Workaround

Brocade vADX customers are recommended to upgrade their Kernel using the instruction yum upgrade kernel” to avoid these vulnerabilities.

Products Confirmed Not Vulnerable

Brocade Network Advisor and Brocade ServerIron ADX are confirmed not affected by these three vulnerabilities

Brocade SAN Products:

·         With regards to Spectre; (CVE-2017-5753) and (CVE-2017-5715), the processors used on the SAN switch products are susceptible to the side-channel attack, however Brocade SAN products will only load and run officially signed FOS firmware.   Since only an officially signed and validated Fabric OS code image can run on Brocade SAN hardware, the SAN switch products are not exploitable with respect to this specific set of vulnerabilities.

·         With regards to the Meltdown vulnerability (CVE-2017-5754), the processors used on the SAN switch products are not affected.

 

 

Note

Brocade Manageability products are not vulnerable to Meltdown or Spectre. However, since the environment that runs the products is not under Brocade's Control, Brocade recommends Customers to apply the recommendation from the vendors.

Revision History

Version

Change

Date

1.0

Initial Publication

January 05, 2018

1.1

Update on BNA, ADX and vADX

January 09, 2018

1.2

Update on vADX workaround and fix plan

January 12, 2018

Disclaimer

THIS DOCUMENT IS PROVIDED ON AN AS-IS BASIS SOLELY FOR INFORMATIONAL PURPOSES AND DOES NOT IMPLY ANY KIND OF GUARANTY OR WARRANTY, INCLUDING THE WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. YOUR USE OF THE INFORMATION CONTAINED HEREIN IS AT YOUR OWN RISK. ALL INFORMATION PROVIDED HEREIN IS BASED ON BROCADE'S CURRENT KNOWLEDGE AND UNDERSTANDING OF THE VULNERABILITY AND IMPACT TO BROCADE HARDWARE AND SOFTWARE PRODUCTS. BROCADE RESERVES THE RIGHT TO CHANGE OR UPDATE THIS DOCUMENT AT ANY TIME.